Hi CISCO-831 & T-Online DSL-flat-Rate Inhaber,

einen CISCO 831R als DHCP-Server, Zeit-Server und nebenbei auch noch als DSL-Router ohne Sicherheitsluecken einzusetzen ist eigentlich nicht die Schwierigkeit, schwierig wird's nur, wenn man bei NULL anfaengt. ;-)
Daher hier ein umfangreiches, funktionierendes Beispiel mit ein paar self-test CheckUp's zur Qualitaetskontrolle.

I hope, it'll helps, BitH...



Hier erst einmal eine gepruefte und funktionsfaehige Beispiel-Konfiguration fuer Deinen CISCO 831-R Router.
Current configuration : 3496 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 
!
no logging buffered
enable secret 5 
enable password 7 
!
username  privilege 15 password 7 
username  15 password 7 
clock timezone MESZ 1
clock summer-time MESZ recurring last Sun Mar 2:00 last Sun Oct 3:00
ip subnet-zero
ip dhcp excluded-address 192.168.255.1 192.168.255.2
!
ip dhcp pool CLIENT
   import all
   network 192.168.255.0 255.255.255.248
   default-router 192.168.255.1
   domain-name customerdomain.local
   netbios-node-type h-node
   lease 30
!
ip audit notify log
ip audit po max-events 100
vpdn enable
!
vpdn-group 1
 request-dialin
  protocol pppoe
 ip mtu adjust
!
!
!
!
!
interface Ethernet0
 description LAN-Interface to DMZ
 ip address 192.168.255.1 255.255.255.248
 ip access-group 102 in
 ip access-group 102 out
 ip nat inside
 ip route-cache flow
 ip tcp adjust-mss 1452
 no ip mroute-cache
 no cdp enable
 hold-queue 100 out
!
interface Ethernet1
 description T-DSL privat
 no ip address
 no ip mroute-cache
 load-interval 30
 pppoe enable
 pppoe-client dial-pool-number 1
 no cdp enable
!
interface Async1
 no ip address
!
interface Dialer1
 ip address negotiated
 ip mask-reply
 ip mtu 1492
 ip nat outside
 encapsulation ppp
 ip tcp header-compression
 ip tcp compression-connections 256
 ip tcp adjust-mss 1452
 load-interval 30
 dialer pool 1
 dialer-group 1
 ppp authentication chap pap callin
 ppp chap hostname @t-online.de
 ppp chap password 7 
 ppp pap sent-username @t-online.de password 7 
 ppp ipcp dns request
 ppp ipcp wins request
!
ip default-gateway 192.168.255.2
ip nat inside source list 102 interface Dialer1 overload
ip nat inside source list 122 interface Dialer1 overload
ip nat inside source static 192.168.255.2 interface Dialer1
ip classless
ip default-network 192.168.255.0
ip route 0.0.0.0 0.0.0.0 Dialer1 254
no ip http server
!
!
access-list 23 permit 192.168.255.0 0.0.0.8
access-list 102 permit ip any any
access-list 122 permit tcp any eq 22 host 192.168.255.2
dialer-list 1 protocol ip permit
banner motd \
Disclaimer                                                                    3
               All actions will be monitored for upcoming trials.
                Unauthorized acccess will result in prosecution.


Hinweis                                                                       7
     Saemtliche Aktionen auf diesem System werden protokolliert und koennen
                          gerichtlich verwendet werden.
                Unerlaubter Zugriff wird strafrechtlich verfolgt.


Avertissement                                                                13
  Toutes les actions sur ce systeme sont inscrites au proces-verbal et peuvent
                          etre utilisees juridiquement.
           L'accces non autorise donne lieu a des poursuites penales.


/www.c-bit.org\
!
line con 0
 logging synchronous
 no modem enable
 stopbits 1
 speed 115200
 flowcontrol hardware
line aux 0
 stopbits 1
line vty 0 4
 access-class 23 in
 exec-timeout 120 0
 password 7 
 login local
 length 0
!
scheduler max-task-time 5000
sntp server 131.188.3.220
end
Fragen zum Thema kann BitH im BBS bestimmt auch nicht beantworten. ;-)

Viel Spass beim Ausprobieren.
(Uebrigens gibt es weitere Konfigurationsvorschlaege für weitere 800-series Modelle unter 800 800R CISCO-800)