Hi CISCO-806 & htp-DSL Flat-Rate Inhaber (dynamische IP-Adressvergabe - Zwangstrennung nach 24 Stunden),

einen CISCO 806R als DHCP-Server, Zeit-Server und nebenbei auch noch als DSL-Router ohne Sicherheitsluecken einzusetzen ist eigentlich nicht die Schwierigkeit, schwierig wird's nur, wenn man bei NULL anfaengt. ;-)
Daher hier ein umfangreiches, funktionierendes Beispiel mit ein paar self-test CheckUp's zur Qualitaetskontrolle.

I hope, it'll helps, BitH...



Hier eine gepruefte und funktionsfaehige Beispiel-Konfiguration fuer Deinen CISCO 806-R Router.
Die 192.168.y.z ist übrigens die IP Adresse des CISCO-Routers selbst, die IP 192.168.y.x steht fuer einen Client bzw. Server, der auf das SYSLOG-Protokoll hört. Dies hat den entscheidenden Vorteil, daß sämtliche Meldungen des Routers mitverfolgt werden koennen, auch wenn man nicht auf dem Router eingeloggt ist. U.U. besteht ja auch die Notwendigkeit, die SYSLOG-Informationen dauerhaft zu speichern - z.B. zum Nachvollziehen der verwendeten IP-Adressen im Falle eines Rechtstreits.
Current configuration : 3715 bytes
!
! Last configuration change at 13:02:43 MESZ Fri Jul 8 2005
! NVRAM config last updated at 13:02:45 MESZ Fri Jul 8 2005
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname routername
!
logging queue-limit 100
logging buffered emergencies
logging rate-limit all 100
enable secret 5 
enable password 
!
username Gytri privilege 15 password 0 
clock timezone MESZ 1
clock summer-time MESZ recurring last Sun Mar 2:00 last Sun Oct 3:00
ip subnet-zero
ip dhcp excluded-address 192.168.y.1 192.168.y.99
ip dhcp excluded-address 192.168.y.200 192.168.y.255
!
ip dhcp pool CLIENT
   import all
   network 192.168.y.0 255.255.255.0
   default-router 192.168.y.z
   domain-name domainname.local
   netbios-node-type h-node
   lease 30
!
vpdn enable
!
vpdn-group 1
 request-dialin
  protocol pppoe
 ip mtu adjust
!
!
!
!
!
!
!
interface Ethernet0
 description LAN-Interface to DMZ
 ip address 192.168.y.z 255.255.255.0
 ip nat inside
 ip tcp adjust-mss 1452
 no ip mroute-cache
 hold-queue 100 out
!
interface Ethernet1
 description htp DSL-Anschluss
 no ip address
 no ip mroute-cache
 load-interval 30
 pppoe enable
 pppoe-client dial-pool-number 1
 no cdp enable
!
interface Dialer1
 ip address 81.14.vvv.www
 ip mtu 1492
 ip nat outside
 encapsulation ppp
 ip tcp adjust-mss 1452
 load-interval 30
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap pap callin
 ppp chap hostname 
 ppp chap password 0 
 ppp pap sent-username  password 0 
 ppp ipcp dns request
 ppp ipcp wins request
!
ip nat inside source list 102 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1 254
no ip http server
no ip http secure-server
!
!
logging origin-id hostname
logging facility syslog
logging 192.168.y.x
access-list 102 permit ip 192.168.y.0 0.0.0.255 any
dialer-list 1 protocol ip permit
banner motd ^C
CISCO 806-R - DSL-Router - A-Z Consulting & Development

Hallo Besucher !

Wenn Du nicht explizit vom Eigentuemer, Besitzer bzw. Betreiber dieses Systems
mit Wartungsarbeiten  betraut wurdest,  befindest Du Dich  illegal  auf diesem
System !!!
Diese Zuwiderhandlung  kann nach dem  deutschen Datenschutzgesetz,  sowie auch
nach internationaler Rechtsgebung strafrechtlich verfolgt werden !
Entsprechende Nachweise in Form von Log-Dateien, Verbindungsdaten sowie durch-
gefuehrte  Aktionen  werden protokolliert  und koennen  zur Verfolgung  dieser
Straftaten gerichtlich herangezogen werden.

Mit anderen Worten: Tschuess, geh woanders spielen !
^C
!
line con 0
 exec-timeout 0 0
 logging synchronous
 stopbits 1
line vty 0 4
 access-class 23 in
 exec-timeout 120 0
 password 7 
 login
 length 0
!
scheduler max-task-time 5000
ntp clock-period 17168933
ntp source Dialer1
ntp master 10
ntp server 192.43.244.18
ntp server 131.188.3.220 prefer
end
Fragen zum Thema kann BitH im BBS bestimmt auch nicht beantworten. ;-)

Viel Spass beim Ausprobieren.



Bei korrekter Einrichtung uebrigens sollte ein sh ip int bri im enabled-Mode ungefaehr folgendes auswerfen:
Interface                  IP-Address      OK? Method Status                Protocol
Ethernet0                  192.168.y.z     YES NVRAM  up                    up
Ethernet1                  unassigned      YES NVRAM  up                    up
Virtual-Access1            unassigned      YES unset  up                    up
Virtual-Access2            unassigned      YES unset  up                    up
Dialer1                    81.14.ccc.ddd   YES IPCP   up                    up


Eingesetzte HardWare:
Cisco Internetwork Operating System Software
IOS (tm) C806 Software (C806-K9OSY6-M), Version 12.2(15)T2,  RELEASE SOFTWARE (fc2)
TAC Support: http://www.cisco.com/tac
Copyright (c) 1986-2003 by cisco Systems, Inc.
Compiled Thu 01-May-03 14:41 by nmasa
Image text-base: 0x80013170, data-base: 0x80A8FBE0

ROM: System Bootstrap, Version 12.2(4r)XM3, RELEASE SOFTWARE (fc1)

 uptime is 48 minutes
System returned to ROM by reload
System restarted at 12:53:03 MESZ Fri Jul 8 2005
System image file is "flash:c806-k9osy6-mz.122-15.T2.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

CISCO C806 (MPC855T) processor (revision 0x501) with 30720K/2048K bytes of memory.
Processor board ID FOC065203UB (2683969583), with hardware revision 0000
CPU rev number 0
Bridging software.
2 Ethernet/IEEE 802.3 interface(s)
128K bytes of non-volatile configuration memory.
8192K bytes of processor board System flash (Read/Write)
2048K bytes of processor board Web flash (Read/Write)

Configuration register is 0x2102
Sonst noch Fragen: mailto:BitH im BBS.



Achso - ich vergass:
Achtet mal oben auf die Konfiguration des Time-Services - diese Konfiguration ist getestet und funktioniert !!!
Ein sh ntp ass im enabled-Mode sollte ungefaehr folgendes auswerfen:
      address         ref clock     st  when  poll reach  delay  offset    disp
*~192.43.244.18    .ACTS.            1    23    64  377   205.5  -463.6    64.8
 ~127.127.7.1      127.127.7.1       9    22    64  377     0.0    0.00     0.0
 ~131.188.3.220    0.0.0.0          16     -   512    0     0.0    0.00  16000.
 * master (synced), # master (unsynced), + selected, - candidate, ~ configured
Ein im enabled-Mode abgesetztes sh ntp sta sollte ungefaehr folgendes offenbaren:
Clock is synchronized, stratum 2, reference is 192.43.244.18
nominal freq is 250.0000 Hz, actual freq is 250.0217 Hz, precision is 2**20
reference time is C2F39205.57BA115F (21:35:33.342 MESZ Sun Aug 24 2003)
clock offset is -463.6277 msec, root delay is 205.49 msec
root dispersion is 528.49 msec, peer dispersion is 64.85 msec
Laufzeit des Routers zum Zeitpunkt dieser Angaben ca. 9h.
Der Router funktioniert, so wie man sich's wuenscht, auch als ntp-Server innerhalb des LANs.



Viel Spass wuenscht BitH... (Uebrigens gibt es weitere Konfigurationsvorschlaege für weitere 800-series Modelle unter 800 800R CISCO-800)