Hi CISCO-PiX501 & T-Online Einwaehler,

hier mal eine Konfiguration fuer eine PiX 501.
Zugegeben, eine PiX hat kein "echtes" IOS zu bieten, aber es erinnert daran und wenn man sich etwas damit beschaeftigt, erwischt man sich dabei, wie man es selbst "PiX-IOS" bezeichnet... ;-)

I hope, it'll helps, BitH...



...im Uebrigen auch aus dem wirklichen Leben gegriffen. Diese Konfiguration laeuft als primary Gateway einer Aussenstelle, VPN-Connections zum Headquarter und Internet-Zugriff direkt zum Provider.
Also eine voellig typische Anwendung, die ueberdies noch allen Unglaeubigen dieser Welt beweist, dass VPN-Gateways auch ohne feste IP's funktionieren !
: Saved
:
PIX Version 6.3(1)
interface ethernet0 10baset
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password  encrypted
passwd  encrypted
hostname 
domain-name 
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
names
access-list  permit ip 192.168.A.0 255.255.255.0 192.168.B.0 255.255.255.0 
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside pppoe setroute
no ip address inside
ip audit info action alarm
ip audit attack action alarm
ip local pool poolinside 192.168.A.0-192.168.A.1
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
conduit permit icmp any any 
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+ 
aaa-server RADIUS protocol radius 
aaa-server LOCAL protocol local 
http server enable
http 192.168.C.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set myset esp-des esp-md5-hmac 
crypto ipsec transform-set myset2 esp-3des esp-md5-hmac 
crypto map newmap 10 ipsec-isakmp
crypto map newmap 10 match address 
crypto map newmap 10 set peer W.X.Y.Z
crypto map newmap 10 set transform-set myset
crypto map newmap 20 ipsec-isakmp
crypto map newmap 20 match address 
crypto map newmap 20 set peer W.X.Y.Z
crypto map newmap 20 set transform-set myset2
crypto map newmap interface outside
isakmp enable outside
isakmp key ******** address W.X.Y.Z netmask 255.255.255.255 
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group t-online request dialout pppoe
vpdn group t-online localname t-online-com/000000000000@t-online-com.de
vpdn group t-online ppp authentication pap
vpdn username t-online-com/000000000000@t-online-com.de password ********* 
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
Cryptochecksum:0123456789ABCDEF01234567890ABCDE
: end
Fragen zum Thema kann BitH im BBS bestimmt auch nicht beantworten. ;-)

Viel Spass beim Ausprobieren.